import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\x3a(:?(\\[\\w+\\])?(\\[\\s\\w+\\s\\]?)?)?\\s?(\\w+)";
final String string = ":[ Admin ] User_name\n"
+ ":[gold][ Admin ] User_name\n"
+ ":[gold]User_name\n"
+ ":[gold][ Admin ] user_name\n"
+ ":User_name";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE | Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}