using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(http:\/\/www\.aparat\.com\/v\/([a-zA-Z0-9-_]+))";
string input = @"http://www.aparat.com/v/bqn5H";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}