$re = '/(http:\/\/www\.aparat\.com\/v\/([a-zA-Z0-9-_]+))/';
$str = 'http://www.aparat.com/v/bqn5H';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);