package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(http:\/\/www\.aparat\.com\/v\/([a-zA-Z0-9-_]+))`)
var str = `http://www.aparat.com/v/bqn5H`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}