re = /(http:\/\/www\.aparat\.com\/v\/([a-zA-Z0-9-_]+))/
str = 'http://www.aparat.com/v/bqn5H'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end