import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=<).*?(REPLACE_ME).*?(?=>)";
final String string = "<REPLACE_ME>this REPLACE_ME cannot be replaced</REPLACE_ME>\n"
+ "<div REPLACE_ME=\"my_attribute\">this REPLACE_ME cannot be replaced</div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}