re = /(?<=<).*?(REPLACE_ME).*?(?=>)/
str = '<REPLACE_ME>this REPLACE_ME cannot be replaced</REPLACE_ME>
<div REPLACE_ME="my_attribute">this REPLACE_ME cannot be replaced</div>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end