import re
regex = re.compile(r"(?<=<).*?(REPLACE_ME).*?(?=>)")
test_str = ("<REPLACE_ME>this REPLACE_ME cannot be replaced</REPLACE_ME>\n"
"<div REPLACE_ME=\"my_attribute\">this REPLACE_ME cannot be replaced</div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")