# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/ORDER BY.*?(?=\)|$)//gmi;t' <<< "SELECT * FROM table ORDER BY name
SELECT a.* FROM (SELECT * FROM table ORDER BY name, creation_date) AS a ORDER BY a.name"