import re
regex = re.compile(r"ORDER BY.*?(?=\)|$)", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("SELECT * FROM table ORDER BY name\n"
"SELECT a.* FROM (SELECT * FROM table ORDER BY name, creation_date) AS a ORDER BY a.name")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)