$re = '/ORDER BY.*?(?=\)|$)/mi';
$str = 'SELECT * FROM table ORDER BY name
SELECT a.* FROM (SELECT * FROM table ORDER BY name, creation_date) AS a ORDER BY a.name';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;