#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)[^?][PG]$|<|PG"
Local $sString = "PPCG" & @CRLF & _
"^P" & @CRLF & _
"^[P^]P" & @CRLF & _
"[^?][PG]$" & @CRLF & _
"(?<!\\..)(?!]).$" & @CRLF & _
"" & @CRLF & _
"[PPCG]" & @CRLF & _
"^[P\^]" & @CRLF & _
"[^\]]$" & @CRLF & _
"^\^?P"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")