$re = '/[^?][PG]$|<|PG/m';
$str = 'PPCG
^P
^[P^]P
[^?][PG]$
(?<!\\\\..)(?!]).$
[PPCG]
^[P\\^]
[^\\]]$
^\\^?P';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);