re = /[^?][PG]$|<|PG/m
str = 'PPCG
^P
^[P^]P
[^?][PG]$
(?<!\\\\..)(?!]).$
[PPCG]
^[P\\^]
[^\\]]$
^\\^?P'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end