import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?m)\\b[A-ZÀ-Ü][A-ZÀ-Ü ’']{2,}(?= |$)";
final String string = "DEL ?PRATO\n"
+ "DEL !PRATO\n"
+ "DEL PRATO!\n"
+ "DEL PRATO1\n"
+ "+DEL PRATO!\n"
+ "DEL? P!RATO \n"
+ "DEL? PRaTO\n"
+ "DEL aPRATO\n"
+ "DEL PRATOb\n\n\n\n"
+ "MARIO’APICELLA\n"
+ "MARIO’ APICELLA\n"
+ "MARIO ’ APICELLA\n"
+ "MARIO ’ ' APICELLA\n\n"
+ "ÒÌFÚ''' CIAOÙÜÒÌ'\",\n"
+ "abcÒÌFÚ'\n"
+ "ÒÌFÚ' abcCIAOÙÜÒÌ'\n"
+ "abcÒÌFÚ' CIAOÙÜÒÌ\n"
+ "ÒÌFÚ'abc' CIAOÙÜÒÌ’\n"
+ "ÒÌFÚ' CIAOÙÜÒÌabc'\n"
+ "ÒÌFÚ' CIAOÙÜÒÌabc' ÒÌFÚ' CIAOÙÜÒÌabc'";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}