import Foundation
let pattern = #"(?m)\b[A-ZÀ-Ü][A-ZÀ-Ü ’']{2,}(?= |$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
DEL ?PRATO
DEL !PRATO
DEL PRATO!
DEL PRATO1
+DEL PRATO!
DEL? P!RATO
DEL? PRaTO
DEL aPRATO
DEL PRATOb
MARIO’APICELLA
MARIO’ APICELLA
MARIO ’ APICELLA
MARIO ’ ' APICELLA
ÒÌFÚ''' CIAOÙÜÒÌ'",
abcÒÌFÚ'
ÒÌFÚ' abcCIAOÙÜÒÌ'
abcÒÌFÚ' CIAOÙÜÒÌ
ÒÌFÚ'abc' CIAOÙÜÒÌ’
ÒÌFÚ' CIAOÙÜÒÌabc'
ÒÌFÚ' CIAOÙÜÒÌabc' ÒÌFÚ' CIAOÙÜÒÌabc'
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)