use strict;
my $str = 'DEL ?PRATO
DEL !PRATO
DEL PRATO!
DEL PRATO1
+DEL PRATO!
DEL? P!RATO
DEL? PRaTO
DEL aPRATO
DEL PRATOb
MARIO’APICELLA
MARIO’ APICELLA
MARIO ’ APICELLA
MARIO ’ \' APICELLA
ÒÌFÚ\'\'\' CIAOÙÜÒÌ\'",
abcÒÌFÚ\'
ÒÌFÚ\' abcCIAOÙÜÒÌ\'
abcÒÌFÚ\' CIAOÙÜÒÌ
ÒÌFÚ\'abc\' CIAOÙÜÒÌ’
ÒÌFÚ\' CIAOÙÜÒÌabc\'
ÒÌFÚ\' CIAOÙÜÒÌabc\' ÒÌFÚ\' CIAOÙÜÒÌabc\'';
my $regex = qr/(?m)\b[A-ZÀ-Ü][A-ZÀ-Ü ’']{2,}(?= |$)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}