import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^ #beginning of the line\n"
+ "[a-z]+ #file name - one or more letters\n"
+ "(?= #assertion declaration\n"
+ ".xml$) #part which should be after the filename";
final String string = "file.sass\n"
+ "file.xml\n"
+ "index.html\n"
+ "model.xml\n"
+ "model.properties\n"
+ "contentModel.xml";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}