$re = '/^ #beginning of the line
[a-z]+ #file name - one or more letters
(?= #assertion declaration
.xml$) #part which should be after the filename/mix';
$str = 'file.sass
file.xml
index.html
model.xml
model.properties
contentModel.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);