import re
regex = re.compile(r"""
^ #beginning of the line
[a-z]+ #file name - one or more letters
(?= #assertion declaration
.xml$) #part which should be after the filename
""", flags=re.MULTILINE | re.IGNORECASE | re.VERBOSE)
test_str = ("file.sass\n"
"file.xml\n"
"index.html\n"
"model.xml\n"
"model.properties\n"
"contentModel.xml")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")