re = /^ #beginning of the line
[a-z]+ #file name - one or more letters
(?= #assertion declaration
.xml$) #part which should be after the filename/mix
str = 'file.sass
file.xml
index.html
model.xml
model.properties
contentModel.xml'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end