const regex = /(?<=<!-- REPLACE_STRING_)[-0-9.]+(?= -->)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=<!-- REPLACE_STRING_)[-0-9.]+(?= -->)', 'i')
const str = `<!-- REPLACE_STRING_21 -->`;
const subst = `60`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);