use strict;
my $str = '<!-- REPLACE_STRING_21 -->';
my $regex = qr/(?<=<!-- REPLACE_STRING_)[-0-9.]+(?= -->)/ip;
my $subst = '60';
my $result = $str =~ s/$regex/$subst/r;
print "The result of the substitution is' $result\n";