re = /(?<=<!-- REPLACE_STRING_)[-0-9.]+(?= -->)/i
str = '<!-- REPLACE_STRING_21 -->'
subst = '60'
result = str.sub(re, subst)
# Print the result of the substitution
puts result