package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d{10})|(\d{3}-\d{3}-\d{4})|(\(\d{3}\)\d{3}-\d{4})
`)
var str = `(888)123-3456
8881231234
888-123-1234
888-1234567`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}