import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d{10})|(\\d{3}-\\d{3}-\\d{4})|(\\(\\d{3}\\)\\d{3}-\\d{4})\n\n";
final String string = "(888)123-3456\n"
+ "8881231234\n"
+ "888-123-1234\n"
+ "888-1234567";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}