#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?<error_count>.*)\s+profileid"
Local $sString = "Error 1 " & @CRLF & _
"profileid = a, jsessionid=b" & @CRLF & _
"Error 1" & @CRLF & _
"profileid = c" & @CRLF & _
"jsessionid=d" & @CRLF & _
"Error 2" & @CRLF & _
"profileid = e, jsessionid=f"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")