import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<error_count>.*)\\s+profileid";
final String string = "Error 1 \n"
+ "profileid = a, jsessionid=b\n"
+ "Error 1\n"
+ "profileid = c\n"
+ "jsessionid=d\n"
+ "Error 2\n"
+ "profileid = e, jsessionid=f";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}