package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?<error_count>.*)\s+profileid`)
var str = `Error 1
profileid = a, jsessionid=b
Error 1
profileid = c
jsessionid=d
Error 2
profileid = e, jsessionid=f`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}