// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^(?<error_count>.*)\s+profileid").unwrap();
let string = "Error 1
profileid = a, jsessionid=b
Error 1
profileid = c
jsessionid=d
Error 2
profileid = e, jsessionid=f";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}