#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:https?://)?(?:w{3}\.)?example\.com/.+"
Local $sString = "https://www.example.com/passing/pass.php" & @CRLF & _
"https://www.example.com/" & @CRLF & _
"www.example.com/pass.php" & @CRLF & _
"www.example.com/" & @CRLF & _
"http://example.com/" & @CRLF & _
"http://example.com/passy-passerson" & @CRLF & _
"example.com/pass.csv" & @CRLF & _
"example.com" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")