const regex = new RegExp('^(?:https?://)?(?:w{3}\\.)?example\\.com/.+', 'gm')
const str = `https://www.example.com/passing/pass.php
https://www.example.com/
www.example.com/pass.php
www.example.com/
http://example.com/
http://example.com/passy-passerson
example.com/pass.csv
example.com
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}