$re = '~^(?:https?://)?(?:w{3}\.)?example\.com/.+~m';
$str = 'https://www.example.com/passing/pass.php
https://www.example.com/
www.example.com/pass.php
www.example.com/
http://example.com/
http://example.com/passy-passerson
example.com/pass.csv
example.com
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);