import re
regex = re.compile(r"^(?:https?://)?(?:w{3}\.)?example\.com/.+", flags=re.MULTILINE)
test_str = ("https://www.example.com/passing/pass.php\n"
"https://www.example.com/\n"
"www.example.com/pass.php\n"
"www.example.com/\n"
"http://example.com/\n"
"http://example.com/passy-passerson\n"
"example.com/pass.csv\n"
"example.com\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")