using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"title=""([a-z]+)""";
string input = @"<a title=""Fruit"" href=""cate1.html"" data-type=""cate"" />
<a title=""apple"" href=""article1.html"" data-type=""article"" />
<a title=""orange"" href=""article2.html"" data-type=""article"" />
<a title=""Vegetable"" href=""cate2.html"" data-type=""cate"" />
<a title=""cabbage"" href=""article3.html"" data-type=""article"" />";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}