$re = '/title="([a-z]+)"/';
$str = '<a title="Fruit" href="cate1.html" data-type="cate" />
<a title="apple" href="article1.html" data-type="article" />
<a title="orange" href="article2.html" data-type="article" />
<a title="Vegetable" href="cate2.html" data-type="cate" />
<a title="cabbage" href="article3.html" data-type="article" />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);