import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "title=\"([a-z]+)\"";
final String string = "<a title=\"Fruit\" href=\"cate1.html\" data-type=\"cate\" />\n"
+ "<a title=\"apple\" href=\"article1.html\" data-type=\"article\" />\n"
+ "<a title=\"orange\" href=\"article2.html\" data-type=\"article\" />\n"
+ "<a title=\"Vegetable\" href=\"cate2.html\" data-type=\"cate\" />\n"
+ "<a title=\"cabbage\" href=\"article3.html\" data-type=\"article\" />";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}