using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=(?:\S*[^\w\s]){2,})\S+";
string input = @"you he==rt are my heart 4++5=9 9-8===1 hyphenated-word";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}