$re = '/(?=(?:\S*[^\w\s]){2,})\S+/';
$str = 'you he==rt are my heart 4++5=9 9-8===1 hyphenated-word';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);