import re
regex = re.compile(r"(?=(?:\S*[^\w\s]){2,})\S+")
test_str = "you he==rt are my heart 4++5=9 9-8===1 hyphenated-word"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")