re = /(?=(?:\S*[^\w\s]){2,})\S+/
str = 'you he==rt are my heart 4++5=9 9-8===1 hyphenated-word'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end