#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b.*\p{Lu}.*\p{Lu}.*\b"
Local $sString = "eHJHJK" & @CRLF & _
"YUIYUI" & @CRLF & _
"LkfjkdJkdfj" & @CRLF & _
"LLdkjkd" & @CRLF & _
"OhdfjhdsjO" & @CRLF & _
"LLLuoiu9898" & @CRLF & _
"Ohdf&jh/dsjO" & @CRLF & _
"auuuu" & @CRLF & _
"JJJJJJJJ" & @CRLF & _
"YYYY99999" & @CRLF & _
"ooooPPPP"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")