import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b.*\\p{Lu}.*\\p{Lu}.*\\b";
final String string = "eHJHJK\n"
+ "YUIYUI\n"
+ "LkfjkdJkdfj\n"
+ "LLdkjkd\n"
+ "OhdfjhdsjO\n"
+ "LLLuoiu9898\n"
+ "Ohdf&jh/dsjO\n"
+ "auuuu\n"
+ "JJJJJJJJ\n"
+ "YYYY99999\n"
+ "ooooPPPP";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}