package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b.*\p{Lu}.*\p{Lu}.*\b`)
var str = `eHJHJK
YUIYUI
LkfjkdJkdfj
LLdkjkd
OhdfjhdsjO
LLLuoiu9898
Ohdf&jh/dsjO
auuuu
JJJJJJJJ
YYYY99999
ooooPPPP`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}