using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?:.(?!\d+x\d+))*\.[^.]+)$";
string input = @"image1-150x150.jpg
image1-225x300.jpg
image1-768x1024.jpg
image1.jpg";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}