const regex = /^((?:.(?!\d+x\d+))*\.[^.]+)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?:.(?!\\d+x\\d+))*\\.[^.]+)$', 'gm')
const str = `image1-150x150.jpg
image1-225x300.jpg
image1-768x1024.jpg
image1.jpg`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}