$re = '/^((?:.(?!\d+x\d+))*\.[^.]+)$/m';
$str = 'image1-150x150.jpg
image1-225x300.jpg
image1-768x1024.jpg
image1.jpg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);