re = /^((?:.(?!\d+x\d+))*\.[^.]+)$/m
str = 'image1-150x150.jpg
image1-225x300.jpg
image1-768x1024.jpg
image1.jpg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end