package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`v=([-\w]+)`)
var str = `http://www.youtube.com/watch?v=3YDz-ftqr1g `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}