const regex = /v=([-\w]+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('v=([-\\w]+)', '')
const str = `http://www.youtube.com/watch?v=3YDz-ftqr1g `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}